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The software described in this book is furnished under a license agreement and may 
be used only in accordance with the terms of the agreement.  
Copyright É2015 Net Software P.C. All Rights Reserved. 
Any technical documentation that is made available by Net Software P.C. is the 
copyrighted work of Net Software P.C. and is owned by Net Software P.C. 
NO WARRANTY. The technical documentation is being delivered to you AS-IS and Net 
Software 2 makes no warranty as to its accuracy or use. Any use of the technical 
documentation or the information contained therein is at the risk o f the user. 
Documentation may include technical or other inaccuracies or typographical errors.  
Net Software 2 reserves the right to make changes without prior notice.  
 
Microsoft, Windows, and the Windows logo are registered trademarks of Microsoft 
Corporation.  
Intel, Pentium are registered trademark of Intel Corporation.  
Other product names mentioned in this manual may be trademarks or registered 
trademarks of their respective companies.  
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General information 

 

Net Control 2 software consists of two main pa rts ð Teacher  Component and Student  
Component .  
 
Teacher Component should be installed on each computer that will be used to control 
other computers.  Student Component should be installed on each computer  that  you 
wish to control. Both components may be in stalled on the same computer.  
 
The Teacher Component should be installed manually using the standard installation 
package. 
 
The Student Component may be installed using one of the following methods:  
- The software may be installed manually on each computer, using the standard 

installation package.  
- The Student Component may be installed automatically through Windows Server's 

Active Directory/Group Policies service and using the special MSI package. The 
special MSI package is available by request for registered  users. 

- The Student Component may be installed on Student computers automatically 
through the built -in Net Deploy tool. To use the Net Deploy service: 
- your network must have a domain  
- you should have local administrative privileges on all remote computers 

where the software should be installed  
- your Windows administrator account should be protected with password  
- sharing services should be enabled in your network  
- Remote Administration Shared Folder should be allowed  

 

A. INSTALLATION WITH STANDARD INSTALLATION PACKAGE 

 
1. Run the Net Control 2 Installation Package (most often net 1100.exe or net 1100r.exe 
file) . 
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2. Read and accept the End-User License Agreement. 
 

 
 
 
3. On the Setup Type  page: 
 

- select Teacher  Components  if you are installing the software on  teacher 
computer;  

- select Student Components  if you are installing the software on student 
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computer, or if this computer should be controlled remotely.  
 

 
 
 

4. Select the folder  and Start Menu folder (optional)  where the Net Control 2 
software will be install ed. 
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5. Select connection mode for the student module (only when youõre 
installing Student Components) :  
 

 
 
Direct connections mode means that teacher computers will connect student 
computers. Teachers will be able to scan the network for groups and 
connections or import connections to the workspace from various sources (text 
or CSV files, Active Directory, network environment, by scanning an IP address 
range of the network). This mode provides more ways for teachers to manage 
groups (classrooms) and connections: each student may be assigned to several 
groups at a time, the teacher can move students from one group to another ; 
this mode is more suitable if each student may be controlled by many (10 or 
more) teachers or teachers use different computer s each time  when they are 
working with Net Control 2 teacher module. Direct connections are òstaticó, 
i.e. always exist in the teacher console, so the teacher can see how many 
computers are connected and unconnected at this time.  
 
On the other hand, this mode may require additional time for configur ing the 
software in  a multi -VLAN environment (i.e. in networks which co nsist of 
multiple VLANs, subnetworks), because the default network scanning routines 
may not work  behind the network router where the teacher computer is 
connected.  This makes impossible to find student computers automatically in 
other segments of the network . And you may need to import th ese connections 
to the workspace with import tools  or by scanning the network by IP address 
range. 
 
Inverse connections  are recommended for both  small and big networks, when 
this student computer should be connected to 1-10 teacher computers max; 
and when the student should be assigned to one group (classroom) only.   
 
Inverse connection model assumes that the student computer connects one or 
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several teachers; creates a connectio n in the teacher workspace and removes 
it when the connection is c losed, i.e. such connections are òdynamicó.  
 
 
Based on the above information , we recomm end selecting Inverse 
connections  mode for situations when:  
- This student computer will not be controlled by more than 10 teachers;  
- The student should belong to one group only. 

 
 

6. Enter address of teacher computers  (only if youõre installing Student 
Components and òMulti-VLANó environment type was selected on previous 
step):  
 

 
 
Here you can enter IP address or DNS name of teacher computers, to which 
this student computer should connect. If you need to specify more than 3 
computers, click òMoreó button and enter the addresses, one address per 
line.  
 

7.  Additional options for the student module installation  
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Enable silent mod e (no signal on connection) ð when it is not enabled, the 
student module will alert with a sound signal and text notification when a 
teacher computer is connecting to  it. Enable this option to suppress the sound 
signals and text notifications.  
 
Always show Net Control 2 toolbar on the screen  ð when enabled, Net 
Control 2 will display Net Control 2 toolbar on student computers. The toolbar 
is a button that is always shown  on the screen of a student computer, at the 
top-right hand corner of the screen (by default); the user can click this button 
to open the Student Console.  

 
 
 

8. If Teacher  Components  are selected, select how the teacher configuration 
will be stored:  
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Individual configuration for each user of this computer  ð the workspace, profiles, 
settings and Net Control 2 -related documents will  be individual for each  user of this 
computer and stored in personal folder of the user, for example:  
òC:\Users\LOGINNAME\AppData\Roaming\Net Control 2ó for Windows Vista/7/2008  
òC:\Documents and Settings \LOGINNAME\Application Data \Net Control 2ó for Windows 
XP. 
 
Common configura tion for all users ð the configuration will be common for all users of 
this computer  
 
Common configuration in the following folder  ð the configuration will be stored in a 
specified folder.  
 
 
 

9. Select Group options  (only if the software was not installed on t his computer 
earlier)  
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Setting up any group name, excepting ò[DEFAULT]ó, will make this computer a part of 
the specified Net Control 2 group.  
If you have several classrooms in the same network, we recommend placing all 
computers of one classroom to the  one the same group. This will help to isolate 
computers of the group from other computers and groups.  Group name  should be the 
same for all computers of the same classroom.  
You can leave this option empty or do not change it, if all computers are present in one 
group or the software will not be installed in other classrooms.  
 
Optionally, together with Group name you can specify the Group password . Setting this 
option up may help prevent access to computers from other groups. The password must 
be the same for all computers of the same classroom.  
 
Group options are allowed to set up only if the software was not installed earlier on this 
computer. If the software was already installed, Group options may be changed only 
using the softwareõs configuration. For more information about groups please refer to 
the Chapter I of this manual.  
 
 
 

10. Select the default Broadcast Desktop  options (only for teacher components) : 
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The Broadcast Desktop Channel  number should be different for every lab of your 
network, otherwis e the transmission sent in one classroom, will be òvisibleó in other 
classrooms. 
 
After installation you can change these settings in the Teacher Console, clicking the 
main menu command N -> Options -> Control Options ; Control/Broadcast page.  
 
 
 
 
 
 
 
 

 
 

 
 
 

11. Review and select the appropriate Additional installation options:  
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Enable Network Discovery Firewall Rule ð enables the Network Discovery rule of 
Windows Firewall in Windows Vista/2008/7. This rule is required for connectivity 
between computers in a local network a nd is enabled by default for òprivateó and 
òworkó network profiles of Windows Firewall. 
 
Update software automatically ð enables automatic update of the software over the 
Internet. When enabled, Teacher Component will check the update server every 14 days 
for available updates , download, and install them automatically when necessary. This 
feature is available in the software  for registered users only.  
 
 
During the installation, Net Control 2 will automatically install the Video Hook Driver, 
which is a required component for Remote Desktop, Broadcast Desktop , and Desktop 
Recorder tools. During the driver setup, the screen may flicker several times.  
 
6. Restart  the  computer after installation.  
 

 
 

B. INSTALLATION OF STUDENT COMPONENTS USING ACTIVE 
DIRECTORY/GROUP POLICIES AND MSI PACKAGE. 

 
Requirements: Network with domain, Windows Server 2003, 2008 or 2012, Active 
Directory services enabled, and administrative privileges.  
 
The Special MSI package described below is available for free-of-charge for registered, 
educational or commercial customers by request.  This package is intended for the 
installation of the Student Component only, in default configuration  and without any 
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additional modification or configuration.  To request the file please visit the following 
page: http://www.netcontrol2.com/downloads  
 
If you need to install the MSI package with some pre -defined settings, for example a 
Group Name, passwords etc., you can either request us for special MSI Builder  tool for 
building custom MSI package for client components deployment  or set up Net Control 2 
Client settings over Active Directory/Group Policy  with administrative templates .  
 
MSI Builder package is available for free of charge for registered or educa tional 
customers by request.  
 
Additional information regarding setting up the client module settings  with Active 
Directory Group Policies please see below in Chapter C.  
 
To install either the standard or custom MSI package:  
 

1. Copy the MSI package to a shared folder on your network.  
 

2.  Log in to the Domain Controller with administrative privileges . For Windows 
Server 2003, click Start -> Programs -> Administrative Tools -> Active Directory 
Users and Computers.  

 

 

3. On the left pane, browse and select the domain w here you wish to deploy the 
package. Right click and select Properties:  
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4. In the Domain properties window, switch to  the Group Policy  tab, click  the "New" 
button, specify  a name for the policy, and then click the "Edit" button:  

 

5. In the Group Policy  window, expand the left tree: Computer Configuration -> 
Software Settings -> Software Installation . Right click within right pane area, 
and click menu command New -> Package from the context menu . 
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6. Browse for the network path to  the Net Control 2 Server MSI package, choose 
"Assigned" and click OK. (Please note : You need to specify the network path to 
the package in this format  -\\SERVER\SHARED_RESOURCE_NAME\PATH\ns.msi. This 
path should be valid and accessible for all user computers where the software will 

be installed ). 
 

 

7. If Windows XP or later is installed on user computers, please enable òAlways wait 
for the network at computer startup and logonó policy in the same Group 
Policy. Open Computer Configurat ion ->Administrative Templates ->System -
>Logon ->Always wait for network at computer startup and logon policy; 
enable it . 
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8. Close Group Policies  and restart the user computers. 
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Net Control 2 will be automatically installed when a User computer applies domain 
settings at Windows startup and logon.  
 

To remove Net Control 2 software from user computers, remove  the Net Control 2 
package from the Software Installation list as described in p.5 of this chapter.  

 

To update Net Control 2 software on user c omputers, remove the Net Control 2 package 
from the Software Installation list as described in p.5 of this chapter and add a new 
package. 
 
 

C. SETTING UP THE NET CONTROL 2 CLIENT AND TEACHER 
SETTINGS WITH ACTIVE DIRECTORY ADMINISTRATIVE TEMPLATES. 

 
Several settings of Net Control 2 Client Module and Teacher module may be set up 
remotely using Active Directory Group Pol icies of Windows Server 2003-2012. 
 

1. Download the administrative templates:  
http://www.netcontrol2.com/getfile?id=nc2client.adm  
and  
http://www.netcontrol2.com/getfile?id=nc2teacher.adm  
 
2. Open the Group Policy Management console: for Windows 2008/2012  click Star t -> 
Administrative Tools -> Group Policy Management. 
 
3. Select a policy where the settings should be deployed. For example Default 
domain policy.  
 
4. Right click it and select Edit  menu command to open Group Policy Management 
Editor . 
 
5. In the editor, a t left pa ne open Computer Configuration -> Policies -> 
Administrative Templates .  
 
6. Right click the Administrative Templates  option and click Add/Remove 
templates  menu command: 
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7. In Add/Remove Templates  window click Add button to add Net Control 2 
template files dow nloaded in p.1  
 
8. When templates are imported you can change Net Control 2 settings in Computer 
Configuration -> Policies -> Administrative Templates -> Classic Administrative 
Templates (ADM)  section. Settings in 32 and 64 bit operating systems are stored 
separately and therefore the administrative templates provide separate sections for 32 
and 64 bit operating systems. If you have mixed computers with 32 and 64 bit operating 
systems, both sections should be configured.  
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D. SCRIPT INSTALLATION WITH STANDARD INSTALLATION 
PACKAGE. 

To install the software using standard Net Control 2 Setup installation package in 
automatic execution mode  and without manual configuration, you can run it with the 
following parameters:  

/SILENT ð run installer in non -interactive m ode without additional prompts  

/COMPONENTS=óadm user comm drv  lspm\hoó - space-separated list of components, 
which should be installed. Possible values:  

 adm ð Teacher Component 

 user ð Student Component, install as service (default)  

 commð Common components (required)  

 drvð Install NC2 Video Hook Driver (required for Remote Desktop, Broadcast 
Desktop and Desktop Recorder tools) 

 lspm\lspð Install Internet Control Engine  in Mode 1: as Internet Explorer plugin 
and with internal control of Internet Explorer. In this mode Net Control 2 can control 
only websites visited in Internet Explorer browser, and cannot control other browsers 
like Firefox, Chrome or Safari. This mode is recommended if you experience issues with 
the default Mode 2.   

 lspm\ho ð Install Internet Control Engine in Mode 2: as protocol layer  module and 
Internet Explorer addon  (this mode is recommended). 

/NORESTART ð Do not restart computer automatically after installation  

/BDCHANNEL:NN ð (optional) specifies Broadcast Desktop channel. Instead of NN please 
specify the number of Broadcast Desktop channel. When not specified, uses the d efault 
channel.  

/GROUPNAME:Name - (optional) ð specifies Group Name for this computer. Used only if 
the software was not earlier installed on this computer.  

/GROUPID:Password  ð (optional) ð specifies Group ID (password) for this computer. Used 
only if the  software was not earlier installed on this computer.  

/ADMPASS:password  (optional) ð set up administrator password for the student module.  

/ADV:ShowMiniToolbar=0  (optional) ð disables Net Control 2 toolbar on student 
computers.  
 

 

Example 1. To install the software, Student components only in default configuration, 
execute the following command line:  

D:\Downloads\net1100r.exe /SILENT /COMPONENTS=óuser comm drv lspm\hoó 
/NORESTART 

 

Example 2. To install Teacher components of the software only, execute the fol lowing 
command line:  

D:\Downloads\net1100r.exe /SILENT /COMPONENTS=óadm comm drvó /NORESTART 

D:\Downloads should be replaced to the actual path to installation package on local 
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computer. 
 
 

E. INSTALLATION STUDENT COMPONENTS OF THE 
SOFTWARE USING NET DEPLOY TOOL. 

 

Requirements:  

- A network with domain ; 

- User who is installing the software remotely must be an administrator  of the 
computer where the software will be installed  (have administrative privileges);  

- The Adminstrative Share (Remote Admin) resource should not be disabled ; 

- Net Control 2 software is already installed on  the Teacher computer ; 

 

The Remote Admin resource.  

Remote installation of Net Control 2 software   with built -in NetDeploy tool is possible 
only if  Administrative Share ("ADMIN$") resource is enabled on computers of the 
network.  
 
1. How to check whether Administrative share is enabled  on client computer  
On Client computer run Command Prompt (press Win+R on a keyboard and type 
cmd.exe) 
in the Command Prompt window type:  
net share  
verify that the ADMIN$ shared resource is in list of resources. 
 
 
2. How to enable Administrative share resource:  
 
Windows XP Professional:  
in Local Security Policy (Windowsõ Start button -> Administrative Tools -> Local Security 
Policy)  select Security Settings -> Local Policies -> Security Options. At right pane select 
"Network access: sharing and security model for local accounts" policy, set this policy to 
"Classic - local users authenticate as themselves"  
 
Windows XP Professional SP3: 

¶ Open Explorer and select Tools -> Folder Options 
¶ Select the View tab and scroll all the way down to the bottom of Advanced 

Settings 
¶ Make sure that "Use simple file sharing (Recommended)" is not selected  

Windows Vista and 7:  
Add the following setting to the system registry of every clie nt computer:  
Key:  HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\System 
Value:  LocalAccountTokenFilterPolicy  :DWORD = 1 
To apply changes after altering this setting you need to restart the client computer.  
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To install the software:  

 

1. Run Net Control 2 Teacher; 

2. Click on Top toolbar's command Net Deploy (Advanced Tools tab) ; 

3. In Network Neighborhood , find and select computers where the software should 
be installed ; 

 

4. Click Install  (òInstall Net Control 2 on Selected Computers ó) button on the top 
toolbar; 

5. Specify local path to Net Control 2 Setup installation package ; 

6. Specify components of the software  that  should be installed ; 

7. Specify Advanced options when necessary; 

 

 

 

7. Click the OK button.  
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The program will try to connect to the remote computer and install the software. If the 
login name and password of the remote computer's administrator differs from the name 
and password of currently logged in user, Net Control 2 will prompt to enter the correct 
login name and password on the remote computer.  

This method of installation will fail if:  

- Your network does not have domain  

- You do not have local administrative privileges on remote computer  

- Provided login name and password of administrator is incorrect  

 

F. UPDATE. 

F.1. Automatic update. 

Net Control 2 has built -in automatic update tool , which can perform automatic update 
for the most important updates : 

- If the Teacher computer is connected to Internet  

- If Automatic Update is enabled in the NC2 Main menu 
N ->Options ->Control Options , Update  page, Download Updat es Automatically  
option is enabled  

 

 

The software will check the NC2 update server every 14 days for available updates. If 
any update is found, the program will download it to the teacher  computer and will 
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deploy it to the user computers as soon as they are connected to the teacher  computer.  

 

Please note : To change the Update options, the program should be started with 
administrative privileges in the system . For Windows Vista/2008/7 /8 , you need to run 
the program as follows:  

- right -click on the Net Control 2 icon on Desktop or in Start ->Programs menu 

- click menu command Run As Administrator  

- confirm execution  

 

F.2. Manual update using standard installation package. 

- download the latest installation package  

- in Net Control 2 Teacher, select the student  computers 

- click menu command N ->Help and Support ->Update Client  

- specify path to Net Control 2 installation package  

 

The package will be uploaded to the student  computers and install. During installation,  
the student  computer will be automatically restarted.  

 

F.3. Update with MSI package. 

If the software was installed earlier via Active Directory/Group Policies and MSI 
package, you can update it, removing the older package from Group Policies, and 
installing the new package. Please see chapter D of this manual.  

 

 

G. FIRST START. 

If  the software is installed on Teacher and Student computers, on teacher computer run 
Net Control 2 Teacher Console (using the link on Desktop or in Start menu).  

 

By default Net Control 2 has only one group - òDefaultó:  
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If you have not set up Group Name parameter on student computers, all student 
computers will be placed to this group. To open the group double click it.  

 

If you have assigned some non-default Group Name  to student computers first you need 
to scan your network for groups:  
- on Groups tab (at the bottom of main window) click Scan button (on left toolbar):  
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To open any found group double click it.  

 

1. If student computers were configured to work in òMulti-VLANó mode (please see 
Chapter A, p.5), the connections should appear  in the teacher console within 20 -30 
seconds automatically.  

 

2. If student computers were configured as òSingle-VLANó mode, open Connections  
tab and click Scan button to perform scanning your network for available computers:  
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If no computers were found i n the process of scanning, please try to click the main menu 
command N ð Connections ð Search Group: 
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